PDA

Просмотр полной версии : Ошибка blockUI requires jQuery v1.2.3 or..(после обновления DLE с версии 9.2 на 10.4)


ilinps
03.04.2015, 17:07
После обновления CMS DLE с версии 9.2 на версию 10.4 (сайт - http://www.uborka.su/job/) появляется сообщение blockUI requires jQuery v1.2.3 or later! You are using v1.11.2
Как исправить эту проблему?

ilinps
03.04.2015, 17:52
Для решения этой проблемы следует в файле jquery.blockUI.js (сайт/engine/job/javascript/...) удалить следующий код:

if (/^1\.(0|1|2)/.test($.fn.jquery)) {
/*global alert:true */
alert('blockUI requires jQuery v1.3 or later! You are using v' + $.fn.jquery);
return;
}

simbata
17.12.2017, 10:20
1)Перейдите в папку wp-content/plugins/jigoshop/assets/js

2)Найдите папку, содержащую нужный плагин, и файл blockui.js

3)Cделайте резервную копию данного файла для дополнительной страховки.

4)Откройте файл и найдите следующую строку кода используя комбинацию клавиш Ctrl+F:
if (/1\.(0|1|2)\.(0|1|2)/.test($.fn.jquery) || /^1.1/.test($.fn.jquery))

5)Для решения проблемы, замените данную строку на следующюю:
if ((/1\.(2\.([3-9]|[1-9][0-9])|[3-9]\.[0-9]*|[1-9][0-9]*\.[0-9]*)/.test($.fn.jquery)) === false )

6)Сохраните внесённые изменения и обновите страницу, на которой выводилось сообщение, Вы убедитесь, что проблема решена.